A5BD_EN_Firmware_20170922_v1.2.5.5beta.rar (2017-09-22 v1.2.5.5)

Discussion in 'Egreat A5 Firmware' started by Rita, Sep 23, 2017.

  1. Rita

    Rita Administrator Staff Member

    Note: Egreat A5 EN firmware includes "Release" version and "Beta" version,
    "Release" version firmware that you can download it click here
    "Beta" version firmware is only for some enthusiasts who like to test some new problems and solved problems in advanced.

    A5BD_EN_Firmware_20170922_v1.2.5.5beta.rar


    I. info
    A5BD_EN_Firmware_20170922_v1.2.5.5beta.rar
    Size: 635,871,767 bytes
    Revised time: Sep, 22nd, 2017, 20:29:51
    MD5:FBF5DF6EE5CAE0EB20DEC0C48C1DF2AB
    DownloadLink:
    http://data.egreatworld.com/A5BD_EN_Firmware_20170922_v1.2.5.5beta.rar



    II.Firmware upgrade instruction

    This version firmware has three ways to update, user data won’t be wiped.

    1. OTA Update, Setting--About--OTA Update
    2. USB Update, please click here.
    3. Forced refresh/recovery system, please click here.

    III.Changelog
    Player: Added pause playback when new switching resolution
    Player: Added support for SGNB production group DIY Mandarin TrueHD track
    Player: Added support for non-standard TrueHD tracks
    Player: Optimize the option can be picked up when the pause
    Player: Optimize the operation and prompts when the breakpoint is on
    Player: Fix 4K UHD original disk built-in ATMOS track source code Play Caton's problem
    Player: Fix Blu-ray zone code setting invalid problem
    User interface: the new local storage device to display the volume name of the function
    Settings: Added 'Pause the playback when switching the refresh rate' switch to the 'Play' menu
    Settings: Added 'True-HD Compatibility Mode' switch to the 'sound' menu
    Poster Wall: Fix single file video date sorting chaos problem
    Poster Wall: Optimize the loading speed.
    Surachai likes this.
  2. Surachai

    Surachai New Member

    Player: Fix 4K UHD original disk built-in ATMOS track source code Play Caton's problem ---> This is fix Atmos track no sound ? ...

    Because , I have some 4K UHD fullrip contain Atmos track and A5 can't play it.

    Thank you ?
    akanit likes this.
  3. andre-asb

    andre-asb New Member

    Thank you!
  4. E_CS

    E_CS Well-Known Member

  5. nenito2k

    nenito2k Well-Known Member

    @Rita nice..but you also said aac 5.1 problem should have been solved late august...
    We need aac issues fixed as 90% of anime are in that format and i Can't enjoy them.
    Hopefully next stable release will finally let me watch them:confused:
  6. stefano nacci

    stefano nacci Member

    videon don't work with 1.2.5.5 .
  7. stefano nacci

    stefano nacci Member

    the good news is that the external hard disks are recognized with her real name and not change at every boot
  8. nenito2k

    nenito2k Well-Known Member

    @stefano nacci can you confirm this VIDON issue ? even for a BETA this should not happen...
  9. Mqulyn

    Mqulyn New Member

    Videon WORK with 1.2.5.5.
    I tried today with 2 movies from external hard disk
    nenito2k likes this.
  10. Flafik

    Flafik Member

    the new bug - very often doesn't work a compulsory soundtrack in series (English constantly joins, and Russian is necessary)
    it is necessary to choose manually a soundtrack with the necessary language
    with VIDON there are no such problems. Everything is all right.
    Last edited: Sep 25, 2017
  11. stefano nacci

    stefano nacci Member

    to me VIDON crash every time and the screen tv is black.
  12. nenito2k

    nenito2k Well-Known Member

    I really hope these bugs stay in he beta..not in next week's stable release!!!!
  13. External subtitles (SRT) synchronization for BD3DMovie works???
  14. nenito2k

    nenito2k Well-Known Member

    @Radoslaw Smetana why would you assume that ? :confused: nothing says it and i don't think so...maybe using vidon?
  15. On vid-on is the same bug. - not working too.
  16. stefano nacci

    stefano nacci Member

    yes, after first update by OTA , vidOn don't work. I solved reinstalled vidON app again. now works.
  17. stb2xxx

    stb2xxx New Member

    disable the subtitle, but it will be activated twice ,fix pls
    pls add Persian in the subtitle and audio selection
  18. Hans

    Hans Active Member

    @Rita,

    Today I watched the movie; The Shallows (2016) BluRay 2160p UHD HDR x265 TrueHD AC3 NLsubs REMUX. With FW 1.2.5.5 and when I switch the ratio to Original, I got a black screen. Full Screen, 16:9 & 4:3 are all okay.

    Also I see that the only Subtiles, is still not okay. As it still is not letting us choose any languesh and it seems to created purely for Asian market, as I did try and all I could find was Asian with English in 1 subtitle, which is only a part of the users. So please fix this part also.

    And also please fix the subtitle color part, as also this is still to white without the correct border (like black) so it is Always readable.

    Why is the volume name only seen in the interface and not in the library?

    And when will the database issue being solved? As it still takes to long to build up and still on the harddrive itself. Which is preventing to watch movies when it is busy?

    For me, I am very disappointed in the progress that is made and the outcome that is being seen. It all takes to long and even the simple, but yet important things for watching video (like descent subtitle) is being there from the moment I bought that A5. And this can't be a time consuming part to fix.

    Additonal; I also watch "The Mummy 2017 BluRay 2160p UHD HDR TrueHD AC3 x265" and also here when selecting Original, the screen is black.

    The resolution is; 3840x2160 16:9 23.976HZ 10Bit
    Video Codec; hevc
    Color Primaries; BT.2020
    Video Bitrate 33.7Mbps
    Last edited: Sep 30, 2017
  19. repir

    repir New Member

    FW 1.2.5.6 ...?
  20. E_CS

    E_CS Well-Known Member

    F/W 1.2.5.6, Egreat Player 2.8.0 for A11/A10/A5 EN/CN players are uploading in progress.
    OTA files temporary mirror on mega.nz: Official link are published on their dedicate topics.
    Last edited: Oct 9, 2017

Share This Page