Egreat A10/A11 The instruction to force to recovery the firmware

Discussion in 'A10 Enthusiast 4K HDR Blu-ray HDD Media Player.' started by Rita, Dec 29, 2016.

  1. Rita

    Rita Administrator Staff Member

    The steps for system forced refresh/recovery system are as follows.

    1. Please download the forced recovery firmware from the company's official website (www.egreatworld.com), the forced recovery firmware contains the following 4 files: update.zip, fastboot.bin, recovery.img, bootargs.bin
    Please do not modify the file name, and copy these four files to the root directory of the U-disk of FAT32 disk format, and must be less than 32GB.
    [​IMG]
    2. Cut off the power supply of this machine, inset the U-disk into the USB3.0 interface of this machine, with a slender hard object (something like the clip after expansion) to insert into the RST small round hole, keep holding down the RST key in RST round hole not loosened, turn on the machine power after holding down the RST button.


    [​IMG]
    3. Keep the posture, release the RST button until the TV screen appears the prompt (the green android small robot animation icon) of being forced refresh/recovery system, the system will automatically complete the forced refresh/recovery system process.


    4. Please be patient, after the forced refresh/recovery system is completed, this machine will automatically restart, after restart, the player can be normally put into use.

    Note

    Last edited: Jun 5, 2017
  2. Awal

    Awal New Member

    i tried several times it's still not working
  3. walexw

    walexw New Member

    Try USB 3.0
    I try force recovery from USB 2.0 and it's not working but it's working on USB3.0
    Awal likes this.
  4. Dennis

    Dennis Administrator Staff Member


    Pls ensure your USB2.0 drive formatted at FAT32, and insert into USB2.0 interface will be more stable than USB 3.0 interface.
    Awal likes this.
  5. walexw

    walexw New Member

    From factory I have 1.1.0.8 firmware. I make OTA update to last firmware. ( it takes 1 hour and 30 min ).
    After that I want to force recovery to 1.1.0.7. I try several time on USB2.0 but no reaction from mediaplayer. I move U-disk in USB 3.0 and it's work from the first time.
    Dennis likes this.
  6. Dennis

    Dennis Administrator Staff Member

    Yes, some of the users also said USB 3.0 available for force upgrading firmware, anyway, try from different angle is a great step!
  7. Caesarea

    Caesarea Member

    This is not working for me:
    I do it like the description above. When holding down the RSTbutton the A10 doesn't start up. Even after I release the RST-button it doesn't start up. If I turn the power supply off and turn it again on without holding the RST-button, then it is starting up.

    After starting up I can upgrade the firmware via USB.
  8. Busy_Boy

    Busy_Boy New Member

    Hi,
    To force Update with 1.1.07 firmware you must before upgrade the A10 with 1.1.2.0 firmware.

    After that:
    1 - Plug your fresh formated FAT32 usb stick with 1.1.0.7 firmware in USB3 port.
    2 - Old RST button and turn on the A10.
    3 - When the green android robot appears release the RST botton.
    4 - The downgrade start...

    ;)
    Last edited: Apr 26, 2017
    Caesarea likes this.
  9. Caesarea

    Caesarea Member

    The USB3 worked for me! Thanks!
  10. Nice Monkey

    Nice Monkey Active Member

    I had to power down my A10 running FW 1.1.2.0 while active to make it come up again using the switch to power it back on. When being in standby state at power off it does not start up at power on with or without the RST button being pressed.
    In fact this is the correct behavior after a power cut it should come back in the state it was in before the power cut. The instructions above need to add this small detail after confirmation of this behavior.

    The recovery procedure does not perform a clean install. Had to do factory reset under advanced setup manually to achieve this. This is not as it should be as some problems might not be recoverable without doing an implicit full wipe prior to doing the emergency FW re-install.
    All other media players I have do this correctly.
    Last edited: Apr 27, 2017
    Rita likes this.
  11. nenito2k

    nenito2k Active Member

    mine came with 1.1.08...and i also did an OTA to 1.1.2.0 !

    But why did you (after that) force recovery to 1.1.0.7 ?! i ask cause maybe i might have bugs that i did not even know exist (stutter, audio, wifi streaming...);

    @Nice Monkey i am afraid of having stutter and not seeing it :D do you advise in my case to force to 1.0.0.7 and reupgrade to 1.1.2.0?
    Last edited: Apr 27, 2017
  12. Busy_Boy

    Busy_Boy New Member

    Hi,

    It's easy to add a wipe data partition before install firmware in updater-script, but why it's not present ? :(
  13. Nice Monkey

    Nice Monkey Active Member

    Don't see a need for that. If there are instabilities a factory reset is more useful.
    Adding a wipe is indeed very easy to do. Strange it was not done.
  14. Busy_Boy

    Busy_Boy New Member

    It's not a HTPC and after that.... Return ! (Full ALL bluray 3D menu)
  15. Caesarea

    Caesarea Member

    Is the factory reset under advanced setup manually the SAME as an implicit full wipe?
    If not, how to do a full wipe?
  16. Nice Monkey

    Nice Monkey Active Member

    It does the same.
    Rita and Caesarea like this.
  17. Caesarea

    Caesarea Member

    Thanks!
  18. REINER

    REINER New Member

    Werkt perfect met usb fat 32 downgrade firmware simpel
  19. I tryed the firmware recovery but fail. In fact, even if I try to do a factory reset under advanced setup manually the factory reset never occur. I keep clicking ERASE EVERYTHING and nothing occur !

    Do I have to do the factory reset ( clean wipe ) before doing the firmware recovery ? If so, how can I do a clean wipe if the factory reset doesnt work ?
  20. After several repeat it does nothing for me.
    Even if I see the android green reboot, the screen last 1 or 2 seconds max and after the player reboot himself to the defaut menu.
    I checked if the firmware change but absolutely nothing. It stays at firmware 1.1.2.o.
    Maybe the firmware goes to 1.1.0.7 but it automatically restart to 1.1.2.0.
    Does the firmware to 1.1.2.0 update automatically or do we have to go to the settings and choose OTA update ?
    I say that because I saw that when restarting after the rebot, I saw the message on the android 5.1 submenu displaying apps 1 to 69 ...

Share This Page