Egreat A10 problem can't passthrough sound DTS and Dolby Atmos

Discussion in 'A10 Enthusiast 4K HDR Blu-ray HDD Media Player.' started by kris chau, Jul 10, 2017.

  1. OlivierQC

    OlivierQC Active Member

    hi all,

    Yes i confirn the DTS 5.1 and DTS HD 5.1 / 7.1 does not works with 1.2.6.6 and the next FW with somes movies ( they works properly with another devices)

    Sometimes in the audio menu we see DTS 5.0 instead of 5.1 for example.

    there is something broken in the FW.





    see you
    Last edited: Feb 4, 2018
  2. OlivierQC

    OlivierQC Active Member

    Hi all,

    I downgraded my Egreat A10 to FW 1.1.0.7 and downgraded my receiver Onkyo 656 to FW1.1.3 (August 2016).

    I have no problem with the English soundtrack DTS/HD/5.1-7.1, but if I change to French or another language, the sound is distorted or nonexistent with DTS/HD/5.1-7.1.

    I have unplugged the Zidoo and installed the Egreat to use the same cable and the same hdmi port of the receiver and still the same problem.

    There is no problem with Dolby in my case, only with DTS.

    I guess if there was a problem with the port hdmi I will have no sound at all, and i have the problem with A10 and A11.

    Here is an example:

    Egreat A10


    I do not have this problem with Zidoo

    Zidoo X10


    See you
  3. OlivierQC

    OlivierQC Active Member

    hi all,

    I will try with vidon tonight

    see you
  4. OlivierQC

    OlivierQC Active Member

    hi all,

    I just tried Vidon and I have the same problem.

    I tried several movies and surprise, with POSTER or Vidon there are some movies in DTS HD french or italian, or etc... that work, and with other movies the DTS HD french or italian or etc.... do not work....

    I also have English atmos soundtrack that work and other movies with English Atmos soundtrack Atmos that do not work.....

    I wish a good continuation to the owner of Egreat devices

    OlivierQC
  5. OlivierQC

    OlivierQC Active Member

    Hi all,

    I have just done a new downgrade (FW 1.1.3) of my Onkyo receiver and now everything is working properly, there is a problem with the last update of the Onkyo.

    If Onkyo receiver owners have problems with the Egreat boxes, I will give you the old Onkyo FW and the procedure, it takes 5 minutes.

    See you

Share This Page