Egreat A5, the instruction to force to recovery the firmware

Discussion in 'A5 Professional 4K HDR Blu-ray HDD Media Player.' started by Tom, Dec 22, 2016.

  1. Tom

    Tom Administrator Staff Member

    The steps for system forced refresh/recovery system are as follows.

    1. Please download the forced recovery firmware from the company's official website (www.egreatworld.com), the forced recovery firmware contains the following 4 files: update.zip, fastboot.bin, recovery.img, bootargs.bin
    Please do not modify the file name, and copy these four files to the root directory of the U-disk of FAT32 disk format. (Very important: the U-disk capacity must be 1GB/2GB/4GB/8GB, don't use 16GB or bigger)
    [​IMG]
    2. Cut off the power supply of this machine, inset the U-disk into the USB2.0 interface of this machine's side (close to the USB3.0 as the below picture), with a slender hard object (something like the clip after expansion) to insert into the RST small round hole, keep holding down the RST key in RST round hole not loosened, plug the machine power supply after holding down the RST button.


    [​IMG]
    1111111.png
    3. Keep the posture, release the RST button until the TV screen appears the prompt (the green android small robot animation icon) of being forced refresh/recovery system, the system will automatically complete the forced refresh/recovery system process.

    4. Please be patient, after the forced refresh/recovery system is completed, this machine will automatically restart, after restart, the player can be normally put into use.

    Note
    • Please do not turn off or cut off the power of this machine during the progress of upgrading, otherwise it may cause this machine can't boot.
    • The file name of the forced recovery system is very important, do not modify the file name(including capital and lower-case).
    • If you failed in a check, it is likely that the file has not been downloaded successfully or the file has been corrupted, please download again.
    Last edited by a moderator: Aug 15, 2018
    andre-asb and Rita like this.
  2. Dennis

    Dennis Active Member

    XBMC 1080p/24hz playback setting: XBMC-Vedio-settings--video--playback--adjust display refresh---on start/stop
  3. akanit

    akanit Member

    Success ok thank
  4. worachai

    worachai New Member

  5. washek

    washek New Member

    Can't find the firmware in official website. Can anyone kindly share the download link pls? Much appreciated!!
  6. washek

    washek New Member

    Can you provide a download link for the said firmware?
  7. E_CS

    E_CS Active Member

  8. washek

    washek New Member

    The prompt (the green android small robot animation icon) at the TV screen is not appearing even after several hours of trying... Its just the red light and lighted Egreat logo is to ensure that the its powered.
  9. washek

    washek New Member

    SOLVED
  10. jpnn80

    jpnn80 New Member

    Hi,

    My A5 has a big problem as after a normal reboot, now it will just display a black 4K video signal after I could play a 4K MKV file the last time I turned it on.

    So I've tried the recovery process with the 4 files from the latest firmware v1.1.2.0 put on a USB key formatted in exFat partition (as although A5 manual specifies to use Fat32, Windows 10 format tool offers only ExFat and NTFS types of partition).

    But my A5 still doesn't start to send any video signal and its led display doesn't show "HELLO" for more than one minute after I plugged the power cable, and pressed the Power ON button on the remote or the box, while keeping the RESET button pushed.

    During this I noticed the Standby Red LED blinking from time to time.

    Do I have to send the box back to my reseller ?
  11. nenito2k

    nenito2k Well-Known Member

    humm...try with RCA cable !
  12. E_CS

    E_CS Active Member

    @jpnn80
    Use a USB flash maximum size 32GB with activity let indication for monitoring, make clean format FAT32 and do recovery firmware v1.1.0.7.
    If you don't have USB with led activity copy to USB recovery.img from rar archive of firmware v1.1.2.0 than will monitoring with Standby Red LED blinking when recovery process start it.
  13. jpnn80

    jpnn80 New Member

    Indeed I could recover from the 1.1.2.0 after formatting my 128GB USB key in FAT32 instead of Exfat, by waiting patiently for the files to be copied while the Standbe Red LED was blinking (By the way this step should me mentionned in the recovery process to make it clearer in case someone unplugs the USB key too soon by thinking there is no transfer).

    But now my problem is that the network card is disabled as soon as I enable DHCP and test a connection, then the network card is enabled if I disable DHCP and connect with a manual IP detected by my router, but my A5 won't connect to Internet or detect my NAS...

    So I will try to recover from 1.1.0.7 to see if this way solves the problem.
  14. Dennis

    Dennis Active Member


    Pls use the method of "force to upgrading firmware", details refer to http://en.egreatworld.com/comunity/...uction-to-force-to-recovery-the-firmware.385/.
  15. jpnn80

    jpnn80 New Member

    I'm still having the network issue whether I downgrade to 1.1.0.7 or upgrade to 1.1.2.0...
  16. Rita

    Rita Administrator Staff Member

    The force recovery is not successful, please must make the USB disk reformat as FAT32, and do the right steps as the list, then it will work well.
  17. JULES

    JULES Member

    hi guys new A5 user here in the UK, I have the stutter problem and cannot download the firmware from the given links all I get is timeout egreat failed to respond, tried 2 browsers so fault is with egreat please help, thanks,,Jules
  18. E_CS

    E_CS Active Member

    Egreat A10/A5 mediafire mirror f/w v1.1.0.7
  19. JULES

    JULES Member

    Thank you ever so much Sir you are a great help :)
    Rita likes this.
  20. ID

    ID New Member

    Hi, how did you do it?
    Thank you

Share This Page