[New Release] A11BD_EN_Firmware_20181101_v1.3.0.9.rar(2018-11-01 v1.3.0.9)

Discussion in 'Egreat A11 Firmware' started by Rita, Nov 2, 2018.

  1. Rita

    Rita Administrator Staff Member

    Note: Egreat A11 EN firmware includes "Release" version and "Beta" version,
    "Release" version firmware that you can download it click here
    "Beta" version firmware is only for some enthusiasts who like to test some new problems and solved problems in advanced.

    A11BD_EN_Firmware_20181101_v1.3.0.9.rar

    I. info
    A11BD_EN_Firmware_20181101_v1.3.0.9.rar
    MD5: 26F65CF888BA65E58B7BB02AC4B30087
    DownloadLink:
    http://data.egreatworld.com/A11BD_EN_Firmware_20181101_v1.3.0.9.rar

    II.Firmware upgrade instruction

    This version firmware has three ways to update, user data won’t be wiped.

    1. OTA Update Setting--About--OTA Update
    2. USB Update, please click here.
    3. Forced refresh/recovery system, please click here.


    III.Changelog

    MusicPlayer: Upgrade Music Player V2.0
    MusicPlayer: Open the music file with the new music player
    VideoPlayer: Add selected online subtitle file can be saved in Video file directory
    VideoPlayer: Support third party video app playback by Egreat player
    VideoPlayer: Fix some M2TS movies playback problem
    VideoPlayer: Fix the black screen problem of some UHD BD Menu
    Poster: Fix the issue of sorting by file date
    Poster: Fix An abnormal problem may occur in repairing the path of the poster wall
    Poster Wall: Update Poster Wall refresh mechanism
    Poster Wall: Optimizing the problem of missing local paths after playing
    UI:New multimedia center theme style
    UI:New multimedia center style entrance replacement function
    Setting:Add theme style switching function
    Setting: Adding Setting-General-Set Boot Mode, which can be set to enter poster wall mode etc automatically after boot
    Setting: Add modify the confirmation prompt for switching resolution
    System: Cancel ‘Optimizing APK’ when boot, to speed the boot
    System: Add press the power button to pop up the shutdown and restart selection box
  2. E_CS

    E_CS Well-Known Member

  3. ConnecTED

    ConnecTED New Member

    Looking the release notes, this firmware release is still suffering from wrong static metadata output to any connected HDR10 display.

    For HDR10 movies, its not passing the complete HDR10 static metadata to the connected displays.

    It's passing correctly the Mastering Display Color Volume (Primaries/White Point cordinates + Min/Max Mastering monitor nits) but not sending any Content Metadata, which is:

    Maximum Content Light Level (MaxCLL) + Maximum Frame-Average Light Level (MaxFALL)

    You will need an HD Fury Vertex (or Linker/Integral) devices which grab the HDR10 infoframe, and connected it between the Egreat and an HDR10 display.

    Find a content in media file where the MediaInfo utility reports that it has a specific MaxCLL / MaxFALL and playback it from the Egreat, you will see that Egreat is sending zeros to any movie MaxCLL/MaxFALL and not the correct movie infoframe for content metadata.

    See that list with metadata per movie, if you have any of these titles.. and you connect a Metadata grabber device between Egreat - TV like an HD Fury product, you will see the problem: https://docs.google.com/spreadsheets/d/15pPvBMCjJogKxt4jau4UI_yp7sxOVPIccob6fRe85_A/edit?usp=sharing

    The movies are including MaxCLL and MaxFALL data, its a fixed number for the whole movie, for the calculation of these numbers, they scan all uncompressed master file (before the encoding to YCbCr) @ post-production houses.

    Since most of the displays are not capable to display 1000/1100/4000 nits (monitors used for mastering), consumers HDR10 TV's can use these numbers (MaxCLL/MaxFALL) and count these values to their internal tone/gamut mapping.

    So the movie will look different if you have these numbers zeros or with correct data coming from the studio per each movie.

    The problem with Egreat is that it's ignoring these numbers and send zero's to the display.

    I have reported this issue from February 2018, when v1.2.8.2 released (2018-02-05).

    Is there any ETA for a fix?
  4. rozel

    rozel Member

    Hi all

    I have been waiting for maybe SACD playback but perhaps I will be waiting a long time. It has been because of this reason I have delayed setting up my Music Server for use with my A11. Last weekend however I managed to get visibility and started playing some of the thousands of tracks I've previously saved down. Essentially I am an Audiophile and was pleasantly surprised as to what it would play and the quality was exceptional.

    So much so I eagerly downloaded the latest update above and plan to have another "music session" later today. However am I missing a trick? Second line down it states "MusicPlayer: Open the music file with the new music player". How do I do this? Last weekend I saw my file lists and on selecting Music, rather than Video, a file list opened and the Music Player opened and played or attempted to. the selected track. Whilst a track was playing I was able to select background and play another track before the first one finished etc etc. No way was I able to open the Music Player by itself and select tracks, but, and this is the bit I'm interested in doing, although the Music Player opens from the list and plays the selected file, I was unable to control the playback from the Music Player; i.e. stop / start /fast forward / fast rewind / play again / pause etc etc.

    How do others play music files from the Music Player - is there any other icon which I am not seeing, to open it, rather than the file list?

    Help would be appreciated please

    Thanks

    roz
  5. Nice Monkey

    Nice Monkey Active Member

    @rozel See my extensive review under A10 (to be honest using my A11 most of the time).
    Yes I confirm the lack of opening Music Player 2.0 directly (is on my list). The only alternative way is going to My App's and selecting it there. It can't even be put in preferences as it is regarded an internal APP. The Music button on the remote neither works to bring it up.

    Quality of playback in fact is influenced by the audio setup only as audio comes out RAW. The good thing from the player 2.0 is that it now passes all HQ source formats untouched correctly (not crummy Android playback). On a good set it sounds as good as possible with the combination of source+set.
    Last edited: Nov 4, 2018
  6. rozel

    rozel Member

    OK - I'll have a look and a play. But can you control playback from the Music Player?
  7. Nice Monkey

    Nice Monkey Active Member

    1) I can pause and jump to next previous title (via the chapter buttons) using the dedicated buttons on the remote. Strange to initiate pause press the stop button on the remote not pause as this will jump to the next track.
    2) Moving the cursor down to lyrics first and controls next one can use the on-screen buttons by navigation of the cursor (or pointer mouse directly). This is my main view by the way and leave it there most of the time.
    3) Moving the cursor left shows the playlist for direct selection of any title.
    3) One can use a smart-phone with HiControl or CetusPlay APP's installed. This is my preference as it allows me to power-off my TV listening to music.
    What are you missing or looking for? This except the bad remote buttons assignment?

    Overall this works nice and easy with only a bit of work needed for the dedicated buttons on the remote (I use an AK86 BT remote with A11).
    I actually like the setup and controls of the new Music Player 2.0, specifically options for player settings and updates are nicely done.

    Updated my review by adding the above there too.
    Last edited: Nov 4, 2018
  8. rozel

    rozel Member

    Hi

    Thanks again for your help, it is much appreciated. Yes I've just had a quick play and worked out you have to press the arrows at the bottom of the Music Player to get to the controls - nice one!
    I'll check out those apps - thanks.

    Main issue now is that last week I was able to play back BDA & DVDA music files - by selecting the folder it allowed me to play the "main movie", as if it were a movie, which in turn played the music in 5.1 or whatever it was recorded in. Now all I get is the folder list BDMV / CERTIFICATE. I did get one BDA folder structure to pop up the Play Main Movie button but when I preseed it nothing but a black screen appeared and froze my Egreat. When it unfroze eventually, I noticed that my Display Settings were screwed. I was careful to select "Music" before entering the files list.

    Am I doing something wrong or will this thing not playback BDA / DVDA music ? Strange though, it did last week on the previous firmware.
  9. Nice Monkey

    Nice Monkey Active Member

    Will check as I am using these formats too.

    These are played by the Movie Player though, not via Music Player as strange as that may sound (they use DVD and BD standards related formats). Normally they also should be played with Menus as they often use multiple Titles rather than Chapters. So going there via Music is the wrong approach (I normally use All and definitely for testing).
  10. rozel

    rozel Member

    Ahhh - I'll check and report back, thank you so much.

    Now I'm exploring what can be done with CetusPlay - assuming I put this on my phone, does the Cetusplay app in the A11 need opening first?
  11. Nice Monkey

    Nice Monkey Active Member

    No CetusPlay and HiControl are active by default. Just install them on the phone they are very supplementary in functionality.
    Don't further discuss HiControl here. It is officially not there as it is formally included for Himedia media players only, but works identical on Egreat too (both use the same SDK from Hisillicon apparently including the support for the APP's client).
    Last edited: Nov 4, 2018
  12. rozel

    rozel Member

    Yep - all works fine now - I really appreciate your support here.
  13. Nice Monkey

    Nice Monkey Active Member

    It was a pleasure. :)
    What is really missing is a good manual, but nobody includes one these days anymore.
    The last brand i had a player from including full manuals was Xtreamer. :(
    Last edited: Nov 5, 2018
  14. Rita

    Rita Administrator Staff Member

    When you upgrade to V1.3.0.9, and can't download the poster well, please do as below instruction.

    1. Posters--Settings--Libraries path management--Delete
    2. Setting--General--Data reset, then reboot the media player, and add poster path again.

    3-1.jpg
    3-2.jpg
    3-3.jpg
  15. wedgehog

    wedgehog Member

    So what? Everyone has abandoned this now? Hey guys how about a network interface please?
  16. nenito2k

    nenito2k Well-Known Member

    @wedgehog i already stated a few days ago that rita is no longer in charge of this forum.. @Richard Xu and a new "BOB" will be the ones taking over.. But since now they are also nowhere to be found...
    Last edited: Dec 27, 2018
    wedgehog likes this.
  17. Markas

    Markas Member

    when you make normal finware 3yer no can make normal finware movies chow 5.0 its normal ? 2 yers no can fix , power on and after drap in screnn eroor , used you self this finware all beta....................
    1 yer ogo i seys forget android 7 , tomorow 2 yer and I seys agen forget ;
  18. nenito2k

    nenito2k Well-Known Member

    Best media player now is dinobot u5 mini... Some here already got one ! Android tv 8.0, enigma2, sat tuner, 4k netflix, and almost no bugs !!!
  19. i take it we have a dodo on our hands now thanks egreat another wasted £400
  20. Karl

    Karl Active Member

    Just a shame the u5 does not have a seperate audio hdmi output like the A11.

Share This Page