[Operation Guidance] New Function Show - SMB/NFS Auto Search Network share

Discussion in 'Functions Operation Guidance' started by Rita, Dec 29, 2016.

  1. Rita

    Rita Administrator Staff Member

    New Function Show - SMB/NFS Auto Search Network Share

    New version supports SAMBA and NFS network share auto search function that don't need to set up and start up by default

    Enter into 'Vedio','Music','Picture' or 'All files' from home page, select 'Search network share' icon.

    Search network share.png
    After a while, system will be in the same LAN, and all of shared device name will be listed. Name including 'SMB' stands for that this device share folders based on SAMBA protocol. Similarly, it's the same as NFS folders.

    Selecting certain device and pressing ok button, A pop-up window appears for inputing account and password(if any question, please enquire the shared device of the owner)

    After inputing corret account and password, system will list all of the shared file name in this device.

    Select one folder what you want to visit.

    After visiting some shared folders, these folders will be recoded, and appear as icon form in the device list, and you can directly select to enter in next time, Don't need to search again or input account and password.

    If you don't need shared folder, you can delete the share folder by pressing 'menu' botton on remote controller.
    Last edited: Dec 30, 2016
    Surachai likes this.
  2. DDenisA

    DDenisA New Member

    Problem in adding of share if the password is set not on an input in the device, and on the folder already inside. The error message of adding is given.
  3. Rita

    Rita Administrator Staff Member

    Yes, this has been in our list, which will be solved in soon. Thanks.
  4. sarahbaras

    sarahbaras New Member

  5. E_CS

    E_CS Well-Known Member

    Rita likes this.
  6. allanon

    allanon New Member

    Hi Rita, I'm trying to connect to my network shared folders(smb), the list of network server appear and when I click to one of them, it doesn't ask for a password but display 2 dot (..) like no subfolders are in there! With others android devices I can found servers and enter in shared folders... Can you help me?
    Solved: I made a force recovery (like mentioned in other tread) and all problems disappear, stuttering playing movies, shared folder now are visible. I hope this is not more necessary in next upgrade! Cheers
    Last edited: Apr 28, 2017
  7. NonNy

    NonNy New Member

    Hi Rita, I already update to the latest FW ( but when I search (both LAN and Wifi) for shared network / folder A5 could not find any of them (A5 keep loading - no response) while other player can.
    akanit likes this.
  8. Caesarea

    Caesarea Member

    Same story with the A10
  9. Caesarea

    Caesarea Member

    I just solved it with my 2 PC's with turning the Firewall off.

    But the A10 cannot see the laptop, even with the same settings as my 2 PC's.
    Otherwise, via the laptop I can see the A10.
    NonNy likes this.
  10. Rita

    Rita Administrator Staff Member

    Can it work well on V1.1.2.0? Also, how and when did you update to V1.1.2.5?
  11. Rita

    Rita Administrator Staff Member

    @Caesarea You also update your A10 to V1.1.2.5 firmware by OTA? When?
  12. Caesarea

    Caesarea Member

  13. Rita

    Rita Administrator Staff Member

    V1.1.2.5 beta firmware is only for Chinese version devices, it is not for English version device, as you can see, that change log is in chinese. But only the Chinese version devices with Chinese firmware can be updated by OTA to V1.1.2.5. But can your device can be updated to V1.1.2.5? Had you ever install Chinese version firmware in your device?
  14. Caesarea

    Caesarea Member

    Before no Chinese version. V1.1.2.5 was my first update. I think I received a Chinese version.

    Would this be a problem for a user in Europe?
  15. Rita

    Rita Administrator Staff Member

    @Caesarea our R&D team double checked, this version didn't OTA for EN version firmware. Which should be the CDN serve little mess. Please kindly recovery back to V1.12.0 or Beta V1.2.0.0.
    Caesarea likes this.
  16. Caesarea

    Caesarea Member

    Thanks, I already did
  17. gridlock

    gridlock New Member

    thanks egreat team , my issues (including the network share problem) are fixed after following the steps to do for each issue.
    my remaining issue is with the egreat player. there's no option to apply my settings (subtitles and aspect ratio) as default for all videos. and i really find it tiring and discomforting to keep on changing aspect ratios and disable subtitles for every video i play.....
    thanks again team egreat for all the effort exerted to make egreat A5 such a great android player.
  18. NonNy

    NonNy New Member

    @Rita No, not on V. either. I've downgrad my A5 to beta still could not find a shared folder automatically. I did some work around by assigning static IP for my PC then create NFS server - this work well A5 can see all my shared networks / folders. The only problem is a poster - A5 did not load a poster or movie data for movies in shared folder (NFS) unless I locate NFS manually each time that device is turn off/on.
  19. E_CS

    E_CS Well-Known Member

    NFS is ip base protocol, NFS server must run static IP. General networking rules server service are highly recommended to run on local static ip.
    Microsoft netbios name protocol use a helper for resolution name WINS or DNS server.
  20. mavpick

    mavpick New Member

    Hi @Rita,

    I am running NFS on 2 separate Synology NAS running DSM 6.1 on the same LAN.
    Egreat player recognizes one of the NAS NFS shares but not the other. Kodi has no problems accessing both.

    I have been trying to debug this for so many hours without success.
    Both NAS has been configured exactly the same except for the static IP and the NFS volume name.

    Please help. Also, when is the A10 getting a firmware upgrade? Been too long and some kodi content servers cannot be updated and is not working although in other media servers it works.

    Richard Xu likes this.

Share This Page